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We want your feedback! 
 
SofTec Microsystems is always on the look-out for new ways to improve its Products and 
Services. For this reason feedback, comments, suggestions or criticisms, however small, 
are always welcome. 

 
 
 
 
 

 
 

 

Our policy at SofTec Microsystems is to comply with all applicable worldwide safety and 
EMC/EMI regulations. Our products are certified to comply to the European New 
Approach Directives and the CE mark is applied on all our products. 
This product as shipped from the factory has been verified to meet with requirements 
FCC as a CLASS A product. 
This product is designed and intended for use as a development platform for hardware or 
software in an educational or professional laboratory. 
In a domestic environment, this product may cause radio interference in which case the 
user may be required to take adequate prevention measures. 
Attaching additional wiring to this product or modifying the product operation from the 
factory default as shipped may effect its performance and cause interference with other 
apparatus in the immediate vicinity. If such interference is detected, suitable mitigating 
measures should be taken. 

 
 
 
SofTec Microsystems 
E-mail (general information): info@softecmicro.com 
E-mail (marketing department): marketing@softecmicro.com 
E-mail (technical support): support@softecmicro.com 
Web: http://www.softecmicro.com 
 

Important 
SofTec Microsystems reserves the right to make improvements to this product, its documentation and software routines, 
without notice. Information in this manual is intended to be accurate and reliable. However, SofTec Microsystems assumes no 
responsibility for its use; nor for any infringements of rights of third parties which may result from its use. 
SOFTEC MICROSYSTEMS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE 
OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY 
THEREOF. 
Trademarks 
SofTec Microsystems is a registered trademark of SofTec Microsystems, Spa. 
Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc. 
Microsoft and Windows are trademarks or registered trademarks of Microsoft Corporation. 
PC is a registered trademark of International Business Machines Corporation. 
Other products and company names listed are trademarks or trade names of their respective companies.
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1 Introduction 

1.1 Overview 

The DEMO9RS08KA2 Demonstration board has been designed for the evaluation, 
demonstration and debugging of the Freescale MC9RS08KA2 microcontroller.  
The DEMO9RS08KA2 can be used as a standalone application, or via its built-in USB-to-BDM 
interface. 

1.2 Package Contents 

The DEMO9RS08KA2 package includes the following items: 
 
� The DEMO9RS08KA2 evaluation board; 
� Two MC9RS08KA2 samples; 
� A USB cable; 
� The SofTec Microsystems “System Software” CD-ROM; 
� The CodeWarrior Development Studio CD-ROM; 
� A Quick Start Guide sheet; 
� This user’s manual. 

1.3 Supported Devices 

The DEMO9RS08KA2 Demonstration Board supports the following devices: 

 
� MC9RS08KA2 family; 
� And any future pin-to-pin compatible device. 

1.4 Recommended Reading 

� Freescale RS08 microcontroller-specific datasheets and application notes; 
� DEMO9RS08KA2 Schematic. 
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2 Hardware Features 

2.1 Demonstration Board Features 

The DEMO9RS08KA2 board features: 
 
1. A MC9RS08KA2 microcontroller (in 8-pin DIP package, already programmed with a 

demo application—in addition, you can also use any other pin-to-pin-compatible device); 
2. A header connector with all of the microcontroller signals; 
3. A power supply section containing: 
 

� A 9-12 V DC Power Supply Input Connector; 
� Power input selection jumpers to select the input voltage input source: 

 
o 9-12 V DC input connector; 
o USB connector. 

 
4. A built-in “USB TO BDM INTERFACE” section which allows the host PC to 

communicate with the microcontroller through a standard USB interface. 
5. An input/output area containing: 
 

� A Reset push-button; 
� One additional push-button; 
� Three user LEDs; 
� An NTC-based temperature sensor; 
� A series of jumpers to connect/disconnect the above controls to/from the 

microcontroller. 
 
6. A prototype area. 
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3 Software Setup 

3.1 Overview 

i 
 

Note: before connecting the Demonstration Board to the PC, it is 
recommended that you install all of the required software first (see 
below), so that the appropriate USB driver will be automatically found by 
Windows when you connect the Demonstration Board. 

 
The Demonstration Board requires that both CodeWarrior Development Studio and SofTec 
Microsystems Additional Components be installed in the host PC. 
 

i 
 

Note: CodeWarrior Development Studio must be installed first. 

3.2 Host System Requirements 

The Demonstration Board is controlled by CodeWarrior Development Studio. The following 
hardware and software are required to run the CodeWarrior user interface together with the 
Demonstration Board: 
 

� A 200-MHz (or higher) PC compatible system running Windows 98, Windows 2000 or 
Windows XP; 

� 128 MB of available system RAM plus 1 GB of available hard disk space; 
� A USB port; 
� CD-ROM drive for installation. 

3.3 Installing CodeWarrior Development Studio 

To install the CodeWarrior Development Studio, insert the CodeWarrior CD-ROM into your 
computer’s CD-ROM drive. A startup window will automatically appear. Follow the on-screen 
instructions. 
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3.4 Installing SofTec Microsystems Additional 
Components 

The SofTec Microsystems Additional Components install all of the other required components 
to your hard drive. These components include: 

 
� The Demonstration Board’s USB driver; 
� The software plug-in for CodeWarrior; 
� Examples; 
� Demonstration Board’s user’s manual; 
� Demonstration Board’s schematic; 
� Additional documentation. 

 
To install the SofTec Microsystems Additional Components, insert the SofTec Microsystems 
“System Software” CD-ROM into your computer’s CD-ROM drive. A startup window will 
automatically appear. Choose “Install Instrument Software” from the main menu. A list of 
available software will appear. Click on the “Additional Components” option. Follow the on-
screen instructions. 
 

i 
 

Note: to install the Additional Components on Windows 2000 or Windows 
XP, you must log in as Administrator. 

 
 



DEMO9RS08KA2 User's Manual 

Page 11 

4 Hardware Setup 

4.1 First Connection 

The Demonstration Board is connected to a host PC through a USB port. Connection steps 
are listed below in the recommended flow order: 
 
1. Install all the required system software as described in the previous section. 
2. Make sure the “POWER SEL” jumper is in the “USB” position. 
3. Make sure the “VDD” jumper is in the “ENABLE” position. 
4. Insert one end of the USB cable into a free USB port of the PC. 
5. Insert the other end of the USB cable into the USB connector on the Demonstration 

Board. The “POWER” LED will turn on. 
6. The first time the Demonstration Board is connected to the PC, Windows recognizes the 

instrument and starts the “Found New Hardware Wizard” procedure, asking you to 
specify the driver to use for the instrument. On Windows XP (SP2) the following dialog 
box will appear. 

 

 
 

Select the “No, not this time” option and click the “Next >” button. 
7. The following dialog box will appear. 
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Click the “Next >” button. 
8. Depending on your Windows settings, the following warning may appear. 
 

 
 

i 
 

Note: this warning is related to the fact that the USB driver used by 
the Demonstration Board is not digitally signed by Microsoft, and 
Windows considers it to be potentially malfunctioning or dangerous 
for the system. However, you can safely ignore the warning, since 
every kind of compatibility/security test has been carried out by 
SofTec Microsystems. 

 
Click the “Continue Anyway” button. 

9. Windows will install the driver files to your system. At the end of the installation, the 
following dialog box will appear. 
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Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure. 
10. The Demonstration Board’s USB driver is now installed on your system. 
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5 Operating Modes 

5.1 Overview 

The Demonstration Board can work in two modes: “standalone” mode and “host” mode. 

5.2 Standalone Mode 

In standalone mode, no PC connection is required. The microcontroller is factory programmed 
with a sample application. 
To run the built-in example: 
 
� Ensure that the “POWER SEL” jumper selects the “UNREG” position. 
� Ensure that the “VDD” jumper selects the “ENABLE” position. 
� Ensure that all of the “I/O ENABLE” jumpers are inserted. 
� Power on the Demonstration Board through the 12 V DC plug-in power supply. 
� The green “POWER” LED on the board should turn on. 
� Depending on the temperature sensed by the NTC network, the “LED0”, “LED1” and 

“LED2” LEDs will turn on as illustrated below.  
 

Sensed Temperature LEDs 

< 10°C 

 

LED2 

LED1

LED0  

between 10°C and 20°C 

 

LED2 

LED1

LED0  

between 20°C and 30°C 

 

LED2 

LED1

LED0  

> 30°C 

 

LED2 

LED1

LED0  
 
� Press the “SW0” push-button. The “LED0”, “LED1” and “LED2” LEDs will blink. 
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5.3 Host Mode 

In host mode the program execution is controlled by the host PC through the “USB” connector. 
You can use the PC to debug the application by, for example, executing the program step by 
step and watching how the microcontroller registers vary, using the provided CodeWarrior 
Development Studio. 
 

i 
 

Note: all MCUs in the RS08 family contain a single-wire background 
debug interface which supports in-circuit programming of on-chip non-
volatile memory. This system does not interfere with normal application 
resources. It does not use any user memory or locations in the memory 
map. The Background Debug Module (also known as Background Debug 
Controller, BDC) uses a single-wire communication interface (via the 
BKGD line) to allow non-intrusive access to target system memory and 
registers. 
Please note that the BKGD line is shared with the PTA3 line and the 
RESET line is shared with the PTA2 line. The user program, therefore, 
must not use the PTA3 line when working in host mode. 

 
To work in host mode (using the built-in USB to BDM interface): 
 
� Make sure that the two “ENABLE” jumpers in the “USB TO BDM INTERFACE” section 

are inserted; 
� Make sure that the “POWER SEL” jumper is in the “USB” position; 
� Make sure that the “VDD” jumper selects the “ENABLE” position; 
� Connect the host PC to the board through the provided USB cable. 
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6 Application Tutorial 

6.1 Overview 

This section will provide a step-by-step guide on how to launch your first project and get 
started with the CodeWarrior user interface. 

6.2 Step-by-Step Tutorial 

The sample application is the same as the one described in the “Standalone Mode” section 
above, with the exception that the “LED0” LED is not used (since this line is shared with the 
BKGD line needed for BDM communication). 
 
1. Set up the board so that it works in host mode (see “Host Mode” above). 
2. Ensure that the Demonstration Board is connected to the PC (via the USB cable) and 

that the board is powered on. 
3. Start CodeWarrior by selecting it in the Windows Start menu. 
4. From the CodeWarrior main menu, choose “File > Open” and choose the “\Program 

Files\Freescale\CW08 V5.1\(CodeWarrior Examples)\RS08\Evaluation Board 
Examples\DEMO9RS08KA2\Asm\Demo\Demo.mcp”. 

5. Click “Open”. The Project Window will open. 
6. The code of this example is contained in the “main.asm” file. Double click on it to open. 
7. From the main menu, choose “Project > Debug”. This will compile the source code, 

generate an executable file and download it to the demo board. 
8. A new debugger environment will open. From the main menu, choose “Run > 

Start/Continue”. The program will be executed in real-time. 
9. From the main menu, choose “Run > Halt”. The program execution will stop. The next 

instruction to be executed is highlighted in the Source window. 
10. From the main menu, choose “Run > Single Step”. The instruction highlighted in the 

Source window will be executed, and the program execution will be stopped immediately 
after. 

11. From the main menu, choose “Run > Start/Continue”. The application will restart from 
where it was previously stopped. 

  
Congratulations! You have successfully completed this tutorial! You can continue to 
experiment with the CodeWarrior user interface and discover by yourself its potentialities. For 
an in-depth guide of all of the user interface features, select “Help > CodeWarrior Help” from 
CodeWarrior Development Studio’s main menu.
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7 Internal Oscillator Trimming 

The MC9RS08KA2 microcontroller features an internal reference clock (32 KHz) which, 
through an FLL circuitry, can be used to generate the microcontroller system clock. The 
internal reference clock can be calibrated (trimmed) with precision. To do so, open the 
Communication Settings dialog box. 
To open the Communication Settings dialog box, enter a CodeWarrior debugging session and 
select “MCU Configuration” from the “SofTec-RS08” menu. The following dialog box will 
appear. 
 

 
 
The MC9RS08KA2 microcontroller’s ICSTRM register and the FTRIM bit in the ICSSC register 
will be then programmed with a specific value which will result in the DCO output frequency 
specified.
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8 Jumper and Connector Settings 

8.1 Jumpers 

Name Reference Description/Pinout 

J101 
 

 

NTC PTA0

PTA1

PTA2

PTA3

PTA4

PTA5

SW0 

RESET

LED0 

LED1 

LED2 
 

I/O  ENABLE 
 
Installed: The indicated microcontroller line is 

connected to the indicated user I/O 
function (default) 

Not Installed: The indicated microcontroller line is not 
connected to the indicated user I/O function 

J202  

1

2

3

 

 

 
 

POWER SELECTION 
 
1-2 (“USB”): The power supply is taken from the USB 

connector (default) 
2-3 (“UNREG”): The power supply is taken from the power 

supply connector (J201) 

J203  

1

2

3

 

 

 
 

VDD SELECTION 
 
1-2 (“ENABLE”): Connects the 3.3V line to the 

microcontroller’s VDD pin and to the 
user I/O area (default) 

2-3 (“DISABLE”): No voltage supplied to the microcontroller 
and user I/O area 

J302  

BKGD 

RESET

 

 

USB TO BDM ENABLE 
 
All installed: The USB to BDM interface is enabled 

(default) 
Not Installed: The USB to BDM interface is disabled 
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8.2 Connectors 

Name Reference Description/Pinout 

J102  

PTA2

PTA3

VDD

GND

PTA0

PTA1

PTA4

PTA5
 

8-Pin Header Male Connector 
 
Replicates all of the microcontroller signals 

J103  

1 2 

3

5

4 

6 
 

BDM Connector (Not Populated) 
 
1. BKGD 
2. GND 
3. N.C. 
4. RESET/VPP 
5. N.C. 
6. VDD 

J201  

2 1 

 

9-12 V DC Power Supply Input Connector 
 
1. 9-12 V DC 
2. Ground 

J301 

 

USB Connector 
 
1. 5 V DC USB Bus Power Supply Line 
2. USB D- 
3. USB D+ 
4. GND 
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9 Troubleshooting 

9.1 USB Driver Problems 

If you connected the Demonstration Board to the PC before installing the SofTec 
Microsystems Additional Components, the Demonstration Board’s USB driver may not have 
been correctly installed on your system. Unplugging and replugging the USB cable is of no 
use, since Windows has marked the device as “disabled”. As a consequence, the PC cannot 
communicate with the Demonstration Board. 
To restore the USB driver (provided the SofTec Microsystems Additional Components have 
been installed), perform the following steps under Windows XP: 
 
1. Connect the Demonstration Board to the PC. 
2. Open the Control Panel (Start > Settings > Control Panel). 
3. Open  the “System” options. 
4. Select the “Hardware” tab. 
5. Click the “Device Manager” button. 
6. The “uDART In-Circuit Debugger” device will be shown with an exclamation mark next 

to it. Double click on this device. 
7. In the “General” tab, click the “Reinstall Driver” button. Follow the on-screen 

instructions. 

9.2 Communication Problems between the PC and the 
Demo Board 

1. Make sure that the “BKGD” and “RESET” jumpers in the “USB TO BDM INTERFACE” 
section are inserted. 

2. Make sure that the microcontroller is powered (The “VDD” jumper in the “POWER” 
section must select the “ENABLE” position). 

3. Make sure that the “POWER SEL” jumper selects the appropriate power source 
(typically “USB” when the board is connected to the PC). 

4. Make sure that the microcontroller is correctly inserted in its socket. 

9.3 “LED0” LED Always Turned On 

The “LED0” LED shares the BKGD line (used for the BDM communication). If you want to use 
this line as a generic user I/O you must enable this feature in your application software and 
remove the “BKGD” jumper in the “USB TO BDM INTERFACE” section of the board. Doing so, 
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however, will make BDM communication between the host PC and the microcontroller 
impossible. 



 

 

 






